Bmw x2 2.0d msport - BMW X2 Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-08-2019, 11:03 AM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 2
Bmw x2 2.0d msport

My X2 is four weeks old having covered 1200 miles, and two days ago from a cold start and driving 1/2 mile it just went into limp mode with smoke coming out of the exhausts. The main dealer is telling me that nothing is showing on the fault diagnosis read out and it is now driving normally. Has any one else had this problem?
Johnrile is offline  
post #2 of 5 (permalink) Old 03-10-2019, 01:44 PM
Member
 
Join Date: Jan 2018
Posts: 43
Have you confirmed your coolant levels? Is this issue repeatable or has it just occurred the once? I would also consider having your water pump/ thermostat checked. Could have just got a faulty part from factory.
Marko is offline  
post #3 of 5 (permalink) Old 03-10-2019, 03:18 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 2
Limp mode

Hi Marko
The car has been at the garage since the event. I assume all is good with the levels, they have told me that it may have regenerated itself and this caused the limp mode. But, surely something would have shown up on the diagnostic checks.
Johnrile is offline  
post #4 of 5 (permalink) Old 03-13-2019, 03:38 PM
Member
 
Join Date: Jan 2018
Posts: 80
Weird that they cant trace the fault through the cars computer, but hopefully it was just a one-off issue. At least it sounds like the dealer is just as curious as you are as to what caused the problem.
Beemz is offline  
post #5 of 5 (permalink) Old 03-13-2019, 07:52 PM
Senior Member
 
Join Date: Feb 2017
Posts: 450
Are they at least taking care of you with a decent loaner? Buying cheaper BMW's like this I noticed they try to give you a rental instead of a BMW loaner. Not cool.
cityrun is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
New X2 MSport 2.0D Xdrrive scotta21955 BMW X2 F39 Owners Registry And Check In Area 4 06-12-2018 02:02 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome